您的当前位置:首页>全部文章>文章详情

phpstudy如何切换设置不同的composer版本及PHP版本

发表于:2023-04-21 08:48:08浏览:417次TAG: #composer #PHP #phpstudy

新的项目需要PHP7.4,但是原来的配置环境默认是7.2,phpstudy死活都改不过来。PHP版本不够高,composer包就不能拉取安装。如何更改 Composer 使用的 PHP 版本?网上找了资料,找到了解决方案。

图片alt

phpstudy这里的自带默认版本是1.8.5的composer,那就得升级一下,下面说说是配置方式:

图片alt

1、到安装目录下复制一个composer1.8.5为新的目录,并且重命名为composer2.3.10

2、到 https://getcomposer.org/download/ 下载最新的composer.phar

图片alt

3、下载下来之后,替换掉原来的文件即可。

图片alt

这样再从项目中打开composer的时候,就会有下拉选择了。

图片alt