您的当前位置:首页>全部文章>文章详情

Thinkphp6在Windows下使用Phpstudy工具升级或全局安装composer

发表于:2023-09-18 10:24:04浏览:481次TAG: #PHP #ThinkPHP #composer

windows下本地安装phpstudy8.1,虽然是自带了composer的安装,但真的和没有一样,版本很低,默认composer版本是1.8.5,这个低版本现在基本上不用了的,也不知道官方为啥不升级一下到Composer 2.0以上。本文章就是教大家如何全局安装composer2.0以上的。

1、phpstudy8.1 下载地:https://www.xp.cn/download.html

2、composer下载地址:https://getcomposer.org/Composer-Setup.exe

安装phpstudy工具后,打开phpstudy将php的版本设置成7.0以上(最好就是7.4)

图片alt

启动Nginx/Apache和Mysql
图片alt

安装composer.exe程序,一直next就好,再选目录的时候要选择到php.exe

图片alt

检查下是是否安装成功,运行cmd输入

composer -v

成功如下:
图片alt

如果原来已经安装了低版本的,升级到最新版composer方法:

composer self-update

如果升级失败,找到php.ini 打开php_openssl.dll扩展,去掉前面的分号即可。extension=openssl
图片alt
图片alt

默认是连接外国的代码镜像的,为了确保网络稳定,建议全局安装挂载阿里云的镜像,运行命令

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

最后我们在phpstudy_pro\WWW 目录下载运行下载TP6的命令就好了.